by kmdm Investigator
Investigator

EE wifi calling not working at home

Hi,

 

I was hoping someone could point me in the right direction for how to solve this. 

 

I have two devices:

 

 * Google Pixel (non-EE), personal mobile

 * Apple iPhone 5S, company mobile

 

In the office at work both devices will use EE WiFi Calling and I see the appropriate indicators next to the EE operator name on both. 

 

At home, the iPhone will still indicate WiFiCall but the Google Pixel will not. I'm not really sure how to debug this further, since:

 

 * It works from the office so WiFi Calling is enabled on my account; and

 * The iPhone works at home so it wouldn't appear to be my router or local network config; and 

 * There's nothing glaringly obvious in the 'adb logcat' output from home (with regards to case insensitive filters lke QCNEJ, WiFi and Wfc)

 

I'm happy to investigate further but I'm not really sure how to given it seems like it just doesn't try to initiate a WiFi calling "connection". 

 

Any help appreciated.

 

Thanks,

Kenny

6 REPLIES 6
by Ace Contributor
Ace Contributor

Re: EE wifi calling not working at home

Hi @kmdm Have you tried just turning your phone off and on again, and also rebooting your router?

 

What happens if you place your Pixel into airplane mode and turn wifi back on, does it pick up EE Wifi calling?

 

I'm more surprised it works on your iPhone now Apple have changed the way it works so if you have a 4G signal it prefers that instead of wifi calling.

by kmdm Investigator
Investigator

Re: EE wifi calling not working at home

Yep - I've tried turning it off/on and rebooting the router. 

 

It consistently 'connects' to WiFi Calling at work and consistently does not at home. 

 

The iPhone shows "EE WiFiCall" at both the office and at home. 

 

The Pixel only shows "EE Wi-Fi Calling" at the office. 

 

I'm at a loss of what to check at this point since I can't really find out the connectivity involved in establishing a WiFi calling 'connection' or how its availability is determined. 

by
EE Employee

Re: EE wifi calling not working at home

Hi and welcome to the community @kmdm

 

Can I get you to try and pop your Pixel into safe mode whilst at home to see if that helps?

 

Many thanks,

 

Lee

by Grand Master
Grand Master

Re: EE wifi calling not working at home

Hi @kmdm

 

Two suggestions: 

 

1. Try changing your wifi channel at home. 

2. Ensure you are connected to the 2.4GHz or if you are change it to the 5GHz signal. 

 

Thanks,

 

 




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by kmdm Investigator
Investigator

Re: EE wifi calling not working at home

Thanks both.

 

I'll try the suggestions given:

 

* Safe mode; and

* Disabling 5Ghz (same SSID)

 

I appreciate the WiFi channel suggestion but I've already ensured it's not on any sort of overlap with surrounding wireless networks (E.g. the full 1, 6, 11 consideration.)

by
EE Employee

Re: EE wifi calling not working at home

Let us know how you get on @kmdm

 

Many thanks,

 

Lee

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.