Highlighted
by Investigator
Investigator

EE 4GEE Started off fast, now super slow

Basically, in our new build apartment, we can't get fibre broadband and looking into it, we would get better speeds with EE 4GEE than a standard copper line. Was all going well at the start getting speeds from 60mbps to 90mbps. In the past few months there's been a major downturn with it ranging now from 5-15. Rarely 15 to be honest. The position of the router hasn't changed. how can it possibly take that much of a drop. Its that bad I'm now starting to look for alternative options as I genuinely can't do nothing on it. Any help appreciated. Ive already rang EE and been told average should be between 10-15mbps apparently. So how was I getting 90 at one stage? lol.

4 REPLIES 4
Highlighted
by
EE Community Support Team

Re: EE 4GEE Started off fast, now super slow

Hi @JackMo90

 

Welcome to the community.

 

Are there any maintenance works going on in your area? You can check on our network status checker.


Chris

 

 

Highlighted
by Investigator
Investigator

Re: EE 4GEE Started off fast, now super slow

Hi mate, No there’s no work going on at all.
Highlighted
by
EE Community Support Team

Re: EE 4GEE Started off fast, now super slow

OK thanks for checking, @JackMo90

 

Could you report a problem on that network status checker please? Our network team will investigate it and send you an update.

 

Chris

Highlighted
by Investigator
Investigator

Re: EE 4GEE Started off fast, now super slow

Done mate! 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.