by geoffers12 Investigator
Investigator

4GEE Router HH70VB - firmware issue/bug

I've looked for an updated firmware - but can't find one.

 

Lan IP

10.1.1.1

Netmask

255.255.0.0

 

If I set the dhcp range to

10.1.1.100 to 10.1.1.200 it sets fine and works

 

If I set the dhcp range to

10.2.1.101 to 10.2.1.201 [which is valid on this subnet mask]

it accepts it [and saves] but on the screen refresh it shows and uses 10.1.1.101 to 10.1.1.201 !


So the firmware is obviously ignoring the subnet mask and assuming that the dhcp range has the first 3 parts of the ip address the same as the lan ip of the unit.

 

[I'm not actually going to be using 255.255.0.0 but it's an easier example to show it not working as it should]

 

11 REPLIES
by geoffers12 Investigator
Investigator

Re: 4GEE Router HH70VB - firmware issue/bug

They’re in an overlay file system so worst case scenario a factory reset will remove the changes and revert to rom versions.
Granted not something we suggest every tom **bleep** and Harry start doing - especially when restricted to using vi, but it must be allowed otherwise it would be blocked Smiley Wink just like changing the subnet mask lol
by geoffers12 Investigator
Investigator

Re: 4GEE Router HH70VB - firmware issue/bug

Nothing as complex or warranty voiding.
ssh
by Grand Master
Grand Master

Re: 4GEE Router HH70VB - firmware issue/bug

As far as I know EE has never provided a download repository for firmware updates. If it decides to do updates it will force-feed them.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
To phone EE: The local rate landline number 020 7362 0200 or Freephone 0800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
by geoffers12 Investigator
Investigator

Re: 4GEE Router HH70VB - firmware issue/bug

I've done some more investigation work.

 

The web config portal sets the start and limit options in /etc/config/dhcp

and only sets the last digit of the ip range -> which is why it's ignoring the netmask

it uses /etc/config/dhcp to generate the /tmp/etc/dnsmasq.conf file

 

This shows the full ip but uses the routers first three octals and the start+limit options to fill in the rest.

 

If I manually edit the /etc/config/dhcp file and change the start option manually to have the full ip showing instead of just the last digit [on a reboot] it generates a new /tmp/etc/config/dnsmasq.conf file with the correct settings

 

I'll investigate more

 

 

by
EE Employee

Re: 4GEE Router HH70VB - firmware issue/bug

Hi @geoffers12 and welcome to the community.

 

Let us know how you get on.

 

Many thanks,

 

Lee

by Grand Master
Grand Master

Re: 4GEE Router HH70VB - firmware issue/bug

What is this "web config portal"? You mean the firmware code in the router, which you are hacking manually? Good luck!

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
To phone EE: The local rate landline number 020 7362 0200 or Freephone 0800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
by geoffers12 Investigator
Investigator

Re: 4GEE Router HH70VB - firmware issue/bug

The web interface that the router gives for you to alter its settings

I’ve not mentioned altering the firmware - just manually editing the config files (which normally is left to the web interface to do)

This isn’t a mobile phone or tablet but a standalone router with its own web server for config changes
by Grand Master
Grand Master

Re: 4GEE Router HH70VB - firmware issue/bug

Sorry, I didn't really mean firmware but manually altering the files held by the OS (the firmware) of the router, which are not normally accessible to the user thro' the admin web interface.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
To phone EE: The local rate landline number 020 7362 0200 or Freephone 0800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
by Grand Master
Grand Master

Re: 4GEE Router HH70VB - firmware issue/bug

I guess you've made an RS232 connection to the router.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
To phone EE: The local rate landline number 020 7362 0200 or Freephone 0800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
by Grand Master
Grand Master

Re: 4GEE Router HH70VB - firmware issue/bug

OK. Just out of interest how do to get into the OS from the menu/form driven web interface to invoke ssh?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Star" button below.
To phone EE: The local rate landline number 020 7362 0200 or Freephone 0800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC
by geoffers12 Investigator
Investigator

Re: 4GEE Router HH70VB - firmware issue/bug

It’s enabled by default - supprised me aswell

Let's get started

Join the EE Community to ask, answer, learn and share.