by Coldfinger Investigator
Investigator

4G modem in bridge mode

Hi,

I'm hoping a clever person will steer me in the right direction.

I'm sure I'm not the first person to have a rubbish ADSL broadband service but with the potential of a good connection via 4G LTE using an external aerial. I'm sure many other people would be interested in a system that integrates a poor ADSL service with 4G similar to below.

Anyway, I purchased a Draytek load balance / failover router (Vigor2862vac) together with a Netgear LB2120 modem/router. The Draytek router is in the broom cupboard where my ADSL cable comes in and the 4G modem is in the loft connected to an external aerial which is essential for a good 4G signal where I live. The two are connected (WAN2 on the Draytek router) via an Ethernet cable (approx 15 metres) to the 4G modem (LAN port). I've configured the 4G modem to be in bridge mode and the router WAN2 port in 'Ethernet / DHCP' mode.

The router's dashboard shows the modem's address as 10.208.199.111 which I believe is a 'local' IP address not a WAN IP address. So I know the two are communicating but not correctly!

I'm trying to find a system that works (router adjacent to the ADSL socket and the 4G modem in reach of the external area) before I sign up with a EE mobile broadband service. I'm just using a 30 day data only sim at the moment with worked OK connected only to my laptop, so I know it fundamentally works.

Having read some other posts I'm not sure if I can connect using bridge mode or whether I've simply set the system configuration incorrectly. I've 'bitten off more than I can chew' and don't know what to do next.

I would really appreciate some advice, do I need different equipment or are my setting simply wrong?

Thanks in advance for any feedback.

1 SOLUTION

Accepted Solutions
by Coldfinger Investigator
Investigator
Solution

Re: 4G modem in bridge mode

Hi Skier641,

Thanks for the reassurance.

This morning I reset the Vigor router back to factory settings and attached the Netgear modem in bridge mode to WAN2 set in 'Obtain an IP automatically'.

 

It worked!

 

I turned off ADSL (WAN1) and was able browse the internet. I tested the speed, ping=27ms, download 42.38Mbps and upload 28.67Mbps. This compares to my ADSL of 2.5Mbps and 0.4Mbps.

 

Thanks for your help in getting this working, it really is appreciated.

 

I'm a bit disappointed that Draytek have taken four days to reply to my technical query and didn't come close to offering a solution.

 

Anyway, now that I have the 4G option, I don't need to rely on BT to provide me with an expensive third world broadband service.

 

Cheers!

 

Adrian

 

19 REPLIES 19
by
EE Community Support Team

Re: 4G modem in bridge mode

Good Morning @Coldfinger.

 

Welcome to the community 🙂

 

Did you try using a standard connection first before setting it up this way?

 

Have you set routers up using bridge mode before?

 

Jon

by Coldfinger Investigator
Investigator

Re: 4G modem in bridge mode

Hi Jon,

The first Netgear modem/router that I did my pre-testing on failed and when the replacement arrived I configured it to bridge mode and connected it to the router.

So this morning I took if off the router, reset it to factory settings and connected it directly to a laptop, so the Netgear/Laptop is separated from my main network.

With the Netgear in ROUTER mode, no DHCP, VPN Pass Through on, DMZ off and failover mode set to 'Mobile Only' and the laptop network IP set to 192.168.5.10, Mask 255.255.255.0, Gateway 192.168.5.1, DNS 8.8.8.8 & 8.8.4.4 I connect to the internet via EE with an IP of 213.205.xxx.xxx.

 

I then set the Netgear to 'Bridge Mode' without changing any laptop settings. Again the modem connected to EE with an IP of 213.205.slightly different. The laptop's network status was ipv4 192.168.5.10, Gateway 192.168.5.1, DNS 8.8.8.8. & 8.8.4.4.

 

So I conclude the modem connects O.K. in router or Bridge mode to a single device i.e. my laptop.

 

Without changing any Netgear settings I then connect it to the WAN2 port of the Vigor2862 router. I've set WAN2 setting to 'Obtain an IP automatically' on the 'Static or Dynamic IP' tab. With this setting the dashboard shows WAN2 'Line/Mode' to be 'Ethernet/DHCP Client' with a IP of 10.115.168.203. I'm not sure where this IP originates I certainly have not set it. BTW the DNS addresses are set to 8.8.8.8. & 8.8.4.4.

 

It seems that I need to be able to configure the Vigor's WAN2 settings correctly for it to work so I need to chase Draytek's support.

 

 

by
EE Community Support Team

Re: 4G modem in bridge mode

Hi @Coldfinger.

 

I think this is a little out of my depth too but I'll try my best.

 

Just to conclude, can you not leave the modem in router mode or does that mean you can't connect multiple devices?

 

Are Draytek also trying to get a solution for you?

 

Jon

by Coldfinger Investigator
Investigator

Re: 4G modem in bridge mode

Hi Jon,

I'll try router mode without DHCP later.

I have a ticket logged with Draytek asking for advice, will advise if they respond.

Adrian

 

by
EE Community Support Team

Re: 4G modem in bridge mode

Thanks @Coldfinger.

 

Let us know how you get on.

 

Jon

by Coldfinger Investigator
Investigator

Re: 4G modem in bridge mode

Hi Jon,

Changed the modem to 'Router Mode' with DHCP off and the Vigor router does not make a connection.

I'll wait to see what Draytek support has to say next

Thanks for your help

Adrian

by
EE Community Support Team

Re: 4G modem in bridge mode

Thanks for the update @Coldfinger.

 

Fingers crossed Draytek can shed some more light on this for you.

 

Jon

by Grand Master
Grand Master

Re: 4G modem in bridge mode

If you are running it in Router mode you must have DHCP enabled. How else can it route if it has nowt to route to?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Skilled Contributor
Skilled Contributor

Re: 4G modem in bridge mode

Coldfinger.  My initial impression is that simply moving the Ethernet cable from WAN2 to the DSL port on your router will solve the issue.  I have a similar set-up i.e. a Netgear LB2120 4G modem (in Bridge Mode) connected to a router (in my case the Netgear Orbi Mesh System).  My system has been setup without issue and I'll try to explain it as easily as I can.

 

As this stage ignore all IP adresses as some you've listed are not relevant.

 

- Set-up the LB2120 in Bridge Mode and ensure that all lights are green.

 

- Connect an Ethernet cable from the LAN port of the LB2120 to the Internet port (DSL port) of your router.

 

- Configure your router as required (I can't really help you here but everything should be more or less default).

 

You can't have a router without DHCP; that's what a router does (amongst other things).

 

 

by Coldfinger Investigator
Investigator

Re: 4G modem in bridge mode

Hi XRaySpeX,

The reason I disabled DHCP in router mode was that I thought this only assigns IP address 'down stream' i.e. in my local network. I reset the Netgear to Router mode and enabled DHCP and then connected it to the WAN2 port of the Vigour router. The Netgear router's DHCP has assinged an IP of 192.168.5.91 to the WAN2 port of the Vigor router. Just in case it was connected but not reporting 'a WAN IP', I tried Ping through WAN2 to an external site and it just timed out, so I don't think it's connected.

Thanks also Skier641.

The DSL port on the Vigor2862 is WAN1 and it's a dedicated ADSL port with a RJ11 socket. I think I was on the right track with it in 'Bridge Mode' and the issue is getting the right configuration for WAN2.

Draytek support replied saying

"From what i've read so far, it seems like you're recieving a carrier grade NATted IP address. The laptop will work differently to the router that's why you're recieving a public IP address on there. You should speak to your provider about public IP address assignments on routers and if it's possible on their network."

I asked them to put this into a sentence that I could pose to EE.

I sort of understand what they are getting at but wouldn't know what to ask for.

Cheers Adrian

by Skilled Contributor
Skilled Contributor

Re: 4G modem in bridge mode

So, the vigor router is a combined modem/router?  I need to look into this router more but, simplistically, will it fall over if you have a working ADSL connection, howver slow?

 

The Netgear modem needs to be in Bridge Mode for the Draytek Vigor to act as the router.

by Skilled Contributor
Skilled Contributor

Re: 4G modem in bridge mode


@Skier641 wrote:

So, the vigor router is a combined modem/router?  I need to look into this router more but, simplistically, will it fall over if you have a working ADSL connection, howver slow?

 

The Netgear modem needs to be in Bridge Mode for the Draytek Vigor to act as the router.


Coldfinger.  From a very quick read of the Draytek specifications I don't believe your combination of router and modem will work as you desire.  Draytek lists compatible 3G/4G dongles and they're connected via USB to the router. 

 

https://www.draytek.co.uk/support/guides/usb-3g-4g-modem-support-list

 

I haven't read in detail what the WAN2 port is capable of at this point.  You may wish to look at an Ethernet to USB converter that may work but I would cut your losses and exchange your router.  In order to use the output from the Netgear LB2120 modem you need a non-ADSL router with just the 4G modem connected (your regular telephone line  ISP connection will no longer work) or go for an ASDL router with built in facility for a SIM card e.g. the Vigor 2862L.

by Coldfinger Investigator
Investigator

Re: 4G modem in bridge mode

Hi Skier641,
Thanks for taking the trouble to look into this issue.
Having just spent £325 on the Vigor router I'm not too keen on having to buy something else.
If I do, I'm more inclined to go with your second suggestion and buy  the Vigor2862L router. I'd put it in the loft where the external aerial leads terminate and run the ADSL line up to it from the ground floor.
Or I could do this with my existing router and buy a USB 4G router (from their list) which has external aerial inputs.
The cost could be offset by flogging the Netgear modem/router.

by Coldfinger Investigator
Investigator

Re: 4G modem in bridge mode

Sorry USB 4G modem not router!

by Skilled Contributor
Skilled Contributor

Re: 4G modem in bridge mode

having read more about this your set-up should work.

 

With the Netgear LB2120 modem in Bridge Mode and the Vigor router as the router, the cable from the modem connected to the WAN2 port (and nothing plugged into the DSL port) how is the WAN2 port configured in the settings?

 

You should not be concerned about or alter/set any static IP addresses at this stage.

by Coldfinger Investigator
Investigator
Solution

Re: 4G modem in bridge mode

Hi Skier641,

Thanks for the reassurance.

This morning I reset the Vigor router back to factory settings and attached the Netgear modem in bridge mode to WAN2 set in 'Obtain an IP automatically'.

 

It worked!

 

I turned off ADSL (WAN1) and was able browse the internet. I tested the speed, ping=27ms, download 42.38Mbps and upload 28.67Mbps. This compares to my ADSL of 2.5Mbps and 0.4Mbps.

 

Thanks for your help in getting this working, it really is appreciated.

 

I'm a bit disappointed that Draytek have taken four days to reply to my technical query and didn't come close to offering a solution.

 

Anyway, now that I have the 4G option, I don't need to rely on BT to provide me with an expensive third world broadband service.

 

Cheers!

 

Adrian

 

by Skilled Contributor
Skilled Contributor

Re: 4G modem in bridge mode

Hurrah!  Great to hear that it's working. Just for my edification; if you enable WAN1 with your ADSL broadband plugged in does favour this as the primary source of your internet connection?

 

I had the same experience with BT (and any other ADSL provider as they all use the Openreach infrastructure).  I haven't had a landline for 8 months or so and haven't missed it.  My only issue is the irony of giving more money to BT via EE.  When Gigaclear implement FTTP I will be going with this service.

by Coldfinger Investigator
Investigator

Re: 4G modem in bridge mode

The reason I bought the Vigor2862 is that there's quite a few ways to set up the load balancing. One way is to balance the distribution according to line speed. So to answer your question, I think you can get it to favour which ever port you want.

 

I don't think we will ever get fibre even though we live in the congested South East. I think it'll only ever be a wireless service so this system is a good sampler.

 

Thanks again

by Skilled Contributor
Skilled Contributor

Re: 4G modem in bridge mode


@Coldfinger wrote:

The reason I bought the Vigor2862 is that there's quite a few ways to set up the load balancing. One way is to balance the distribution according to line speed. So to answer your question, I think you can get it to favour which ever port you want.

 

I don't think we will ever get fibre even though we live in the congested South East. I think it'll only ever be a wireless service so this system is a good sampler.

 

Thanks again


From reading just a few sections of the User Guide for your router it certainly seems an excellent and configurable unit.  Since I went with the EE 4G solution for my internet I have had zero issues: the signal has never gone down (except for duing a couple of brief powercuts) and the signal has remained strong.  The up/down speeds diminshed slightly when the trees came into leaf and have risen again since they've fallen.

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.