by RiggaTheMighty
Visitor

Very slow everything on 4G

Hi, 

 

I’ve been struggling for months with really slow connection all the time on my IPhone XR. 

Calls, apps, games, music, etc

everything just grinds to a halt when I’m not on Wi-fi. 

 

If I search for something on google for instance.... it just thinks about it for a minute and then says “google.co.uk could not provide a secure connection” 

i click reload a few times and it loads up the search results. 

 

On my apps, even the EE app, I click on it to open and it just sits on a blank screen for a while and nothing happens.

If I close it and reopen it a few times, it sometimes loads up. 

 

Just wondered if anyone had any suggestions of what it could be? 

 

Thanks 

1 SOLUTION

Accepted Solutions
by Grand Master
Grand Master
Solution

Re: Very slow everything on 4G

@RiggaTheMighty  on the device go to settings/General/reset/reset network settings. Your device will reboot and you will need to put your Wi-Fi password back on the device after this. Please try cellular data. 

1 REPLY 1
by Grand Master
Grand Master
Solution

Re: Very slow everything on 4G

@RiggaTheMighty  on the device go to settings/General/reset/reset network settings. Your device will reboot and you will need to put your Wi-Fi password back on the device after this. Please try cellular data. 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.