by Wadha
Visitor

Very slow! 4G

Hi 

 

I contacted the customer services regarding this issue! 

 

Report ID is 2381730

 

the internet is very slow even I cannot sent a photo in Whatsapp!!!

 

I can’t complete any Facetime and JustTalk calls always cutting!!!  I live in central london SW7 

 

My plan is 20 GB 4G data and i hav enough data

 

their reply

 

Network update: We could not find a problem in SW7 5HE. This may have been a one off and we therefore recommend you restart your device. If you are still having problems, please call us on 150. Your Report ID is 2381730.

F5314E5C-027B-4751-B863-1EF329E9B268.pngUploading speed !!!

 

Any sugguestion? I hate slow internet

 

7 REPLIES 7
by Ace Contributor
Ace Contributor

Re: Very slow! 4G

Hi @Wadha 

 

Have you tried a network reset on your Phone at all?

 

On Apple: 

To do this go into Settings > General > Reset > Reset Network Settings.

 

on other devices just try the same things in those settings 

by
EE Community Support Team

Re: Very slow! 4G

Hi @Wadha

 

Thanks for coming to the community.

 

Does this happen in other areas?

 

Are your calls and texts working ok?

 

Speak soon.

 

Leanne 🙂

 

 

by Ace Contributor
Ace Contributor

Re: Very slow! 4G

My speeds in London E14 are as bad, I'm just told it's due to various factors when I've complained. EE don't seem to be improving the 4G network round here.

 

eespeedtest.jpeg

by jakewaring89
Explorer

Re: Very slow! 4G

Screenshot_20190815-135734_Chrome.jpg

Thi

is in E10. Wish I'd never left Tesco. EE has been so slow and poor service everywhere and I travel a lot for week. Nightmare

Screenshot_20190815-135734_Chrome.jpg

 

by jakewaring89
Explorer

Re: Very slow! 4G

Hilarious. Think it was too bad to upload the images. Basically I'm getting 2mb download speed

by
EE Community Support Team

Re: Very slow! 4G

Good Afternoon @jakewaring89

 

Thanks for coming to the community. 

 

How long have you been experiencing this?

 

Have you reported this to our technical care team?

 

Speak soon, 

 

Katie 🙂

by Star Contributor
Star Contributor

Re: Very slow! 4G

Hi Jake,

Have you got 4G switched off as your device is showing H+ which is 3G?

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.