by philip42h Investigator
Investigator

SMS texts not received when WiFi calling is enabled

Various online services use SMS text messaging to provide access codes for two factor authentication (e.g HMRC and certain bank transactions). I am finding that I am not receiving these SMS texts if WiFi calling is active - they simply never arrive. But if I turn WiFi off completely (and go and stand out in the garden) text messages arrive as they should.

 

Is this a known issue with WiFi calling?

 

Does this mean that I am also likely to be missing phone calls too?

 

Outbound calling and texting is just fine with WiFi calling active ...

1 SOLUTION

Accepted Solutions
by philip42h Investigator
Investigator
Solution

Re: SMS texts not received when WiFi calling is enabled

Asking the community - or, at least consulting the community forums is the way to go ...

 

Those "fairly significant updates a few weeks ago" were a thing called 'Nougat' apparently.

 

There's a thread entitled No Wifi Calling on S7 Edge since Nougat update where, amongst other things the poster shows how to find the wifi calling settings in Nougat - they were a little obscure before; they are no well and truly buried: Settings > Applications > More: Show system apps > Phone (the first of three such) > More settings > Wi-Fi calling

 

... which, since the Nougat update, is shown as 'off'.

 

Turning it back on restores correct functionality of wifi calling (for me, for now, at least) so that's one mystery solved. Smiley Happy

 

Now, I'd better go and look into what else 'Nougat' may have done unbidden ... Smiley Mad

 

Edit: OK the requisite settings aren't quite as 'buried' as I implied above - one just needs to approach it via 'Phone' rather than 'Settings'. As on the help pages it's:

2. Switch WiFi Calling on

  • From the home screen, tap Phone.
  • Tap the Menu icon. (3 dots)
  • Tap Settings.
  • Scroll down to and tap Wi-Fi calling switch to On.

Nonetheless, Nougat does appear to have switched it at least half off!

 

 

 

5 REPLIES 5
by Grand Master
Grand Master

Re: SMS texts not received when WiFi calling is enabled

@philip42h  What device is this and have you called customer services and spoken to them about this ?  Your line might need to be reset, and I receive calls and texts just fine with wifi calling enabled. 

by philip42h Investigator
Investigator

Re: SMS texts not received when WiFi calling is enabled


@Chris_B wrote:

@philip42h  What device is this and have you called customer services and spoken to them about this ?  Your line might need to be reset, and I receive calls and texts just fine with wifi calling enabled. 


Chris,

Thanks for responding. It's an S7 with all the updates I've been offered - i.e. there were some fairly significant updates a few weeks ago.

 

I have previously received texts while wifi calling was enabled, am not aware of having missed any calls and previously thought that wifi calling worked perfectly. It's only over the last week or so that I have become aware of missing things - i.e. SMS messages that HMRC have issued and test texts that I have got my daughter to send me don't arrive with wifi turned on but do with it turned off. (I haven't tried disabling wifi calling itself yet).

 

No, I haven't called customer services yet ... I thought I'd ask the community first ... Smiley Happy

by Grand Master
Grand Master

Re: SMS texts not received when WiFi calling is enabled

@philip42h  I have no issues on my i7 with wifi calling being enabled.  Have you tried a network reset on the device? 

by philip42h Investigator
Investigator
Solution

Re: SMS texts not received when WiFi calling is enabled

Asking the community - or, at least consulting the community forums is the way to go ...

 

Those "fairly significant updates a few weeks ago" were a thing called 'Nougat' apparently.

 

There's a thread entitled No Wifi Calling on S7 Edge since Nougat update where, amongst other things the poster shows how to find the wifi calling settings in Nougat - they were a little obscure before; they are no well and truly buried: Settings > Applications > More: Show system apps > Phone (the first of three such) > More settings > Wi-Fi calling

 

... which, since the Nougat update, is shown as 'off'.

 

Turning it back on restores correct functionality of wifi calling (for me, for now, at least) so that's one mystery solved. Smiley Happy

 

Now, I'd better go and look into what else 'Nougat' may have done unbidden ... Smiley Mad

 

Edit: OK the requisite settings aren't quite as 'buried' as I implied above - one just needs to approach it via 'Phone' rather than 'Settings'. As on the help pages it's:

2. Switch WiFi Calling on

  • From the home screen, tap Phone.
  • Tap the Menu icon. (3 dots)
  • Tap Settings.
  • Scroll down to and tap Wi-Fi calling switch to On.

Nonetheless, Nougat does appear to have switched it at least half off!

 

 

 

by philip42h Investigator
Investigator

Re: SMS texts not received when WiFi calling is enabled


@Chris_B wrote:

@philip42h  I have no issues on my i7 with wifi calling being enabled.  Have you tried a network reset on the device? 


Thanks again Chris - maybe I should have swallowed my pride and gone with an iPhone ... Smiley LOL

 

As above, sorted now - I think ...

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.