by Sair95
New Member

Problems with 4G

Hi, I have been having problems with my 4G and I have had a SIM replacement. I have recently taken my iPhone to EE to get repaired and I am currently using a loan phone whilst mine is being repaired. I am still experiencing problems with my 4G on the Sony phone I have on loan, whenever I am using data, the 4G sign does not show, instead I am seeing the E sign which I have been told is for very bad internet. Please could you advise as to what I should do? thanks 

2 REPLIES 2
by Grand Master
Grand Master

Re: Problems with 4G

Maybe the loan phone only does 2G. What model is it?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by
EE Community Support Team

Re: Problems with 4G

Good Morning @Sair95

 

Welcome to the EE Community.

 

Can you confirm what phone it is?

 

Does this happen in more than one location?

 

Speak soon, 

 

Katie 🙂

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.