by timboothby Investigator
Investigator

Problems since IPv6 upgrade, IPv4 DHCP failing

Hi,

 

I have a Sufrace tablet pc running Windows 10 (1607) with an embedded 4G modem. It has an ee contract SIM in it. This has worked fine for a year or so until recently when it seems the account was upgraded to IPv6.

 

Now I get a public IPv6 address but an autoconfiguration 169.254.X.X IPv4 address. Eventviewer showing IPv4 DHCP is failing. Browsing the internet is erratic - lots of DNS errors, missing pictures, stylesheets etc. Some sites work ok, presumably ones which support pure IPv6.

 

test-ipv6.com sometimes fails to load altogether, sometimes says IPv6 is ok but no IPv4 and sometimes says I have NAT64 and an IPv4 NAT address. 

 

Currently I can ping bbc.co.uk and see an IPv6 address but if I try and browse it I get a DNS error in the browser - it was working earlier albeit with missing immages.

 

If I put a Vodafone SIM in it I get an IPv4 address only and everything works fine, so the issues seem related to the ee SIM.

 

Any thoughts?

 

Thanks,


Tim

15 REPLIES 15
by
EE Community Support Team

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Hi @timboothby

 

Thank you so much for coming to community 🙂

 

By any chance, have you spoken to our Technical team about this.

 

When you select the EE drop down, there is an option to select live chat.

 

Thanks 

 

Richard

 

🙂

by timboothby Investigator
Investigator

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

I thought I'd try here first before support. It's a company account and I they probably won't speak to me without the account details etc.

 

Interestingly if I put the ee SIM in my phone it works fine - IP4 only.

by
EE Employee

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Good Morning @timboothby

 

I'm going to see if I can get some info for you!

 

Leave this with me.

 

Thanks - Karen. Smiley Happy

by
EE Employee

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Hi @timboothby

 

Just a quick question have you tried manually adding/changing the APN?

 

If not can you try these settings please;

 

Name Internet

APN everywhere

Proxy Leave Blank

Port Leave Blank

Username Leave Blank

Password Leave Blank

Server Leave Blank

MMSC http://mms/

MMS Proxy 149.254.201.135

MMS Port 8080

MCC 234

MNC 30

Authentication Type PAP

APN Type If you have choices select internet + mms otherwise type in *

 

Let me know how it goes!

 

Thanks - Karen. Smiley Happy

by pablopatito Investigator
Investigator

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

I have exactly the same issue with an HP Elite x2 running Windows 10 Pro. Tried different APNs, including the one above. 

 

Get an IPv6 address fine, but IPv4 is set to a 169 address.

 

I don't know how to specify MMS details in Windows though (not sure if this matters).

 

 

by
EE Employee

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Hi @pablopatito

 

You don't need to specify the MMS details on Windows.

 

Do you get the same issue with the above details?

 

Thanks - Karen. Smiley Happy

by pablopatito Investigator
Investigator

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Hi Karen

 

Yes I do.

 

by
EE Employee

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Thanks for getting back to me @pablopatito

 

Can you try these please;

 

Name Internet

APN everywhere

Proxy Leave Blank

Port Leave Blank

Username eesecure

Password secure

Server Leave Blank

MMSC http://mms/

MMS Proxy 149.254.201.135

MMS Port 8080

MCC 234

MNC 30

Authentication Type PAP

APN Type If you have choices select internet + mms otherwise type in *

 

Thanks - Karen. Smiley Happy

by pablopatito Investigator
Investigator

Re: Problems since IP6 upgrade, IPv4 DHCP failing

OK, tried those. Still not working. 

by
EE Employee

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Hi @pablopatito

 

Are you able to try the SIM's in an alternative device to see if the same issue occurs?

 

Is there a particular site/app you're having issues with?

 

Thanks - Karen. Smiley Happy

by pablopatito Investigator
Investigator

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Yes, the SIM works fine in my iPhone. 

 

Most websites don't work, or if they do (eg bbc.co.uk) they only partially work. Presumably because I don't have an IPv4 address, only IPv6.

 

I have tried a different EE SIM and have the same problem.

 

 

 

by
EE Community Support Team

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Good afternoon @pablopatito

 

Thanks for getting back to my collegue @Karen_C I would advise to now get in touch with our technical team.

 

If you are a pay monthly personal EE customer, when you select the EE option, you will be given an option to live chat with a member of our online chat team.

 

If not, then please give them a call on the numbers provided.

 

Thank you

 

Richard

 

🙂

by timboothby Investigator
Investigator

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Just to update, after speaking to 10! different people in support over 2 days I've got this sorted.

 

 

The fix was to set APN to orangeinternet AND on the APN settings page set the IP type to IPv4.

 

I tried the ipV4 setting with the everywhere APN and this didn't work.

 

Many thanks to Amy in business support for her assistance with this.

 

by
EE Employee

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

Hi @timboothby

 

Glad you are now sorted.

 

Many thanks,

 

Lee

by EEtmt
Visitor

Re: Problems since IPv6 upgrade, IPv4 DHCP failing

I have an iPhone 8 but my device doesn’t allow me to see the network settings. 

 

EE - how do I change this so I can use the products that I want on my device?

Let's get started

Join the EE Community to ask, answer, learn and share.