by windyboi Investigator
Investigator

OpenVPN not working

Hi, I have an OpenVPN server running at home. I can connect to it fine, apart from when I am tethering from my EE phone.

 

I have tried moving from UDP 443 to TCP 443, but still I cannot connect. The TCP handshake goes through but then I get a reset that drops the connection. I can only think it must be some kind of DPI happening that is not allowing my VPN connection to complete.

 

I have phoned Technical Support, who don't know what OpenVPN is, but they disabled the adult filter. I have turned my phone off and on again, but the issue still persists. 

 

Please advise 

17 REPLIES 17
by Grand Master
Grand Master

Re: OpenVPN not working

I don't understand your set up. Need more description.

 

What type of BB system are you running at home?

 

From where can you connect to it fine?

 

What are you tethering to your phone?

 

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by windyboi Investigator
Investigator

Re: OpenVPN not working

Thank you ever so much for your help.

 

At home, I am running a TalkTalk modem connected to my pfSense firewall. I've had this setup for four years with openvpn running.

 

I have been able to connect to it with tethering from my previous mobile provider (Vodafone), and I can also connect from hotel wifi, coffee-shop wifi, etc. The only problem I have observed is when tethering from my EE phone. 

 

I am on MacOS running Tunnelblick openvpn client

 

Hope this helps clarify things

by Grand Master
Grand Master

Re: OpenVPN not working

Sorry, I don't get where tethering comes into it. Aren't you just making a Net connection from your phone to your TT modem & onward to your server? The server isn't using the phone's mobile data to get itself onto the Net?

 

Or are you saying that you are trying to replace your TT BB connection by your phone's mobile network?

 

When you are in a coffee-shop you are not tethering to anything but just making a Net connection.

 

Is this just a terminology misunderstanding? Mobile tethering - The complete guide .

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by windyboi Investigator
Investigator

Re: OpenVPN not working

Hi

 

I think this might be getting unnecessarily overcomplicated. Let me describe a use case to help you understand

 

1. I am on a train, on my Macbook, and I want to connect in to my home network.

2. Tether from iPhone (EE) to Macbook.

3. Try and connect from Macbook to home network. [Does not work]

 

 

by Grand Master
Grand Master

Re: OpenVPN not working

Ah, now I see! There's a lappy in the equation being tethered to your mobile for the purpose of getting on the Net.

 

How does the lappy address the home network?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by windyboi Investigator
Investigator

Re: OpenVPN not working

🙂 

Using dynamic DNS. My Mac completes a TCP handshake with my OpenVPN Server, but then receives a reset. Again, only happens when I am utilising the tethering from EE phone.

 

I have not yet done a packet capture on my server

by Grand Master
Grand Master

Re: OpenVPN not working

It might just be an EE IPv6 issue. Recently EE introduced IPv6 on its network, but it doesn't fall-back to IPv4 nicely. Can you change the Profile/APN on your EE devices to APN Protocol = IPv4 only?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Grand Master
Grand Master

Re: OpenVPN not working

@XRaySpeX   Not possible on a iPhone unless you know how to create a profile to install on the device.  

by Grand Master
Grand Master

Re: OpenVPN not working

@Chris_B : Oh, was it an IPhone? I never noticed being more interested in the Internet connection. Pity!

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Grand Master
Grand Master

Re: OpenVPN not working

@XRaySpeX @windyboi   There is away to create the profile that will allow this to work over IPv4.  I’ll do some research on this and hopefully I’ll come back with something.  

by Grand Master
Grand Master

Re: OpenVPN not working

Hi @windyboi 

 

What profile are you using on openvpn? 

 

I use openvpn on EE network without any issues, so I wouldn't say it's  an ipv6 issue, unless this is an Apple issue (I use Android).

 

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by Grand Master
Grand Master

Re: OpenVPN not working

@Northerner : The OP is running the OpenVPN server on the TT BB network, which is IPv4 only, & accessing it from an EE mobile which is using IPv6 but doesn't fallback to IPv4 well.

 

I think you are running a OpenVPN client on your EE mobile, which is a different kettle of fish.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Grand Master
Grand Master

Re: OpenVPN not working

@XRaySpeX 

 

I know so do I. The app allows you to specify the ipv4 or 6 ip address but I suspect the setting is set to pull the info from the server which is conflicting if their home BB is v4 only.  That saidy my Sky internet is 4 not 6, and as I said, I have no issues on EE connecting to my home network via EE V6 or my VPN service which is v6.




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by Grand Master
Grand Master

Re: OpenVPN not working

@Northerner : Are you running a VPN server on your home Sky BB network?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Grand Master
Grand Master

Re: OpenVPN not working

@windyboi : As an experiment to confirm or otherwise my theory about EE & IPv6 how about getting a £10 EE PAYG SIM, putting it in your iPhone & see if that can do what you wanna do in accessing your home VPN server from your tethered lappy? EE PAYG does not use IPv6.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by windyboi Investigator
Investigator

Re: OpenVPN not working

Hi, thanks for replies. Based on this info, I'm going to allow ipv6 on my firewall as it is currently blocked, and see what happens. Will report back

 

Thanks

by Grand Master
Grand Master

Re: OpenVPN not working

Thanks! You're welcome 🙂 ! Glad I could be of assistance.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.