by perskine Investigator
Investigator

No data on iPhone 6 since porting number to EE, Apple verified phone is unlocked

So I moved x2 numbers from Vodafone and 02 to EE in December, the vodafone ported with no issues, the 02 ported the number successfully but the device does not allow any data connection other than wifi. 

 

I have spoken with EE's technical department, although helpful nothing they have suggested has worked and it was upscaled to a higher tech team who tried one thing and have given up...

 

I checked with Apple to find out if the phone had been unlocked from the old netwrok (O2), they confirmed it has.

 

I then tried using an external unlock service, just to double down on that. No joy.

 

EE/Apple have suggested all the normal tricks, reset network settings, backup/restore etc etc, done that a ton of times, no joy.

 

I've been sent a replacement SIM, no joy.

 

I've put the EE sim in another unlocked iphone - it works fine.

 

I've tried a vodafone sim in my iphone - no data, phone calls are fine, but exactly the same issue with data. To clarify, this phone prior to the port was with 02 and worked fine - I'm really wishing I hadn't bothered now!

 

So anyone got any suggestions, I had a phone that worked fine, porting the number appears to have worked, but the phone just doesn't work (data) anymore - one thing I want to try is another 02 sim, as maybe the APN settings just haven't been overwritten - I can't find any way of deleting/editing them and if I try patching them using the site hosted in NZ it says the APN settings can't be installed as there is already an existing APN certificate in place - could this be the issue?

 

Any help appreciated!

8 REPLIES 8
by perskine Investigator
Investigator

Re: No data on iPhone 6 since porting number to EE, Apple verified phone is unlo

I've just borrowed a colleagues 02 Sim, guess what, the data works fine. So someone at EE please investigate this again. 

 

You've ported my number from 02

The phone is unlocked

The phone/messages works fine

The data does not work, the sim has been tested and works on another device

The phone is NOT broken as using an 02 sim proves this

 

When the porting was done, something went wrong, the data settings must be locked to 02 - how can this be changed?

by Profile closed
Not applicable

Re: No data on iPhone 6 since porting number to EE, Apple verified phone is unlo

Hello @perskine is the option settings>general>profiles visible on the iPhone? If so what profiles are saved on it? Any old o2 ones will block your data connection working. Removing them then performing a network reset (you will have to re-enter WiFi passwords) should restore service. 🙂
by Grand Master
Grand Master

Re: No data on iPhone 6 since porting number to EE, Apple verified phone is unlo

@perskine!   Have you deleted the o2 profile that's on your device?  

 

Goto setimgs>General>Profile> and delete the o2 profile.    

by perskine Investigator
Investigator

Re: No data on iPhone 6 since porting number to EE, Apple verified phone is unlo

I'm running 10.2, in this build there is no option in Settings/General for profile...

 

and I've already performed a network settings reset (multiple times)

 

 

by perskine Investigator
Investigator

Re: No data on iPhone 6 since porting number to EE, Apple verified phone is unlo

no option to do that in 10.2

by
EE Community Support Team

Re: No data on iPhone 6 since porting number to EE, Apple verified phone is unlo

Hi @perskine,

 

Thanks for joining the EE Community.

 

Have you tried restoring your iPhone via iTunes with the EE SIM inserted?

 

James

by perskine Investigator
Investigator

Re: No data on iPhone 6 since porting number to EE, Apple verified phone is unlo

I have restored it with the old sim, empty sim and with new sim...

 

by
EE Community Support Team

Re: No data on iPhone 6 since porting number to EE, Apple verified phone is unlo

Good afternoon @perskine

 

Thank you for getting back to my colleague @James_B

 

It's a huge shame non of the answers or troubleshooting tips offered have helped to resolve this for you.

 

I would advise to please GET IN TOUCH with our technical support team and ask to escalate this to Technical Level 2.

 

I wish you all the luck to try and resolve this.

 

Please let us know how you get on.

 

Thanks

 

Richard

 

🙂

 

 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.