by KayJW Investigator
Investigator

New SIM 4G not working

Everytime I try switch on my 4G a message keeps coming up saying "Could not activate mobile data network, You are not subscribed to a mobile data service". What does this mean? How do i make my internet work? This is a new SIM that i got and put in my phone 2 days ago.

 

Thanks

5 REPLIES 5
by Grand Master
Grand Master

Re: New SIM 4G not working

@KayJW   Have you restarted the device?  Is cellular data enabled on the device?  Have you allowed the apps to use cellular data ?  

by KayJW Investigator
Investigator

Re: New SIM 4G not working

Hi @Chris_B , yes i have restarted the device, cellular data is enabled and i have allowed the apps

by
EE Community Support Team

Re: New SIM 4G not working

Good Afternoon @KayJW

 

Are you currently in the UK?

 

Was this SIM a replacement?

 

Are you able to make calls and texts ok?

 

Speak soon, 

 

Katie 🙂

by KayJW Investigator
Investigator

Re: New SIM 4G not working

Hey @Katie_B 

 

Yeah I’m currently in the UK

 

Kind of as I had a T-Mobile sim before which was pay as you go, so it is kind of an upgrade from that

 

Yes I’m still able to make calls and text

 

Thanks 

by
EE Community Support Team

Re: New SIM 4G not working

Hi @KayJW

 

Thanks for confirming. 

 

I would recommend getting in touch with our technical care team.

 

Please keep me updated with your progress, 

 

Katie 🙂

 

 

 

 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.