by Mikekadi Established Contributor
Established Contributor

My 4G is very slow

I’ve got a 4G signal but I’ve done a Speedtest and it’s around 1.5-2Mbps and considering I’m on the max plan 100gig a month it’s not good 

4 REPLIES 4
by Grand Master
Grand Master

Re: My 4G is very slow

Have you checked the Network Status Checker  ?

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Mikekadi Established Contributor
Established Contributor

Re: My 4G is very slow

Yeah it doesn’t say anything is broken or down 

by Ace Contributor
Ace Contributor

Re: My 4G is very slow

@Mikekadi I’ve had this happen a few months ago and the network checker didn’t state an issue, and others were not having this issue in my area.  I was dipping between E and 4g all morning then decided to turn my phone off completely for a short time out of frustration. ( I never turn mine off usually at all, it’s constantly on ). When I turned it back on,  it was back to normal speeds. Not saying it’s a fix, but worth a try. 

by
EE Community Support Team

Re: My 4G is very slow

Hi @Mikekadi

 

I see @Watkins07 has offered a great suggestion here.

 

Did that help at all?

 

Are you aware of any other users in the area having similar problems?

 

Chris

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.

Recent solutions