by beckychud Investigator
Investigator

My 4G doesn't work anywhere, hasn't worked for the last 2/days

My 4G doesn't work,  hasn't done for last 2 days,  I still have 2GB data and the 4G symbol is displayed 

6 REPLIES 6
by Profile closed
Not applicable

Re: My 4G doesn't work anywhere, hasn't worked for the last 2/days

Hello @beckychud what phone do you have?

 

You can check your area for any faults or planned maintenance by entering your postcode in the Network Status Checker:

 

https://myaccount.ee.co.uk/networkchecker/checkservice

 

You can also sign up for My Places just below to receive text updates from EE. 🙂 

by
EE Community Support Team

Re: My 4G doesn't work anywhere, hasn't worked for the last 2/days

Thanks for helping @Profile closed

 

Morning @beckychud.

 

If you can let us know what device you have?

 

We will see what we can do to help 🙂

 

Thanks, Leanne.

by beckychud Investigator
Investigator

Re: My 4G doesn't work anywhere, hasn't worked for the last 2/days

Thanks for the help, I have a Samsung S7 Edge 

by
EE Community Support Team

Re: My 4G doesn't work anywhere, hasn't worked for the last 2/days

Thanks @beckychud

 

What happens when you try and access data?

 

Have you checked the network status checker to see if any problems are showing in your area?

 

Speak soon 🙂

 

by beckychud Investigator
Investigator

Re: My 4G doesn't work anywhere, hasn't worked for the last 2/days

When I try to use that data it just says no internet connection or can't load this page.  

Yes I have checked the signal checker and it says everything is fine here. 

by
EE Community Support Team

Re: My 4G doesn't work anywhere, hasn't worked for the last 2/days

Thanks @beckychud,

 

Can you try this for me.

 

Go to Settings > Data Usage, Is this showing as ticked?

 

Speak soon 🙂

Let's get started

Join the EE Community to ask, answer, learn and share.