by optimusqueef Investigator
Investigator

Data not working after upgrade

I just chose my new upgrade plan yesterday. Got a text to confirm I was now on 4gee max plan, but now my data doesn't seem to work? It still shows as connected to 4g and my usage is still within limits. Everything works fine through WiFi, just getting nothing through mobile data. 

7 REPLIES 7
by Profile closed
Not applicable

Re: Data not working after upgrade

Hello @optimusqueef how long ago has it been since you upgraded? Upgrades can take up to 24hrs to complete and some services may not work or be available during this time. Restarting your phone and turning mobile data off then back on now and again to keep the network connection refreshed can help. 🙂

by optimusqueef Investigator
Investigator

Re: Data not working after upgrade

I applied for upgrade yesterday (Sunday) and new phone as just arrived today!! Will put sim into new phone when I'm home and maybe it will work? 

by
EE Community Support Team

Re: Data not working after upgrade

Hello @optimusqueef

 

Thanks for coming here.

 

What device have you upgraded to?

 

Also what happens when you use the internet?

 

Speak soon 🙂

by optimusqueef Investigator
Investigator

Re: Data not working after upgrade

I have upgraded to galaxy s8 though currently using old device, new phone has just arrived now so will try sim in new phone 

by
EE Community Support Team

Re: Data not working after upgrade

Great @optimusqueef

 

Let us know how you get on 🙂

by optimusqueef Investigator
Investigator

Re: Data not working after upgrade

Currently using new phone over Wi-Fi. Tried online search over 4g and I was directed to add on page. It says I have 2gb/2gb remaining

by
EE Community Support Team

Re: Data not working after upgrade

Hi @optimusqueef,

 

Please get in touch with customers services so we can take a quick look at your account.

 

Thanks

 

James

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.

Recent solutions