by NOLAN1984
Explorer

Change phones NAT TYPE

If anyone can help. I work in the UK a lot so take my PS4 away with me, I play online using my phones "tethering and portable hotshot" mode on my Sony Xperia Z5. I'm sure all worked fine before my phones update but now when I connect my PS4 I'm getting a strict type 3 Nat type so making it harder to connect to some players / chat. Any way of changing the settings to open or at least moderate type 2? Thanks

15 REPLIES 15
by Grand Master
Grand Master

Re: Change phones NAT TYPE

Hi, 

 

Have you tried this.

 

Thanks, 




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by Grand Master
Grand Master

Re: Change phones NAT TYPE

You won't be able to set DMZ or forward ports on your mobile. That's for real routers not mobile devices.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by NOLAN1984
Explorer

Re: Change phones NAT TYPE

Yeah that's all I've found guides like above but for routers. Is is some setting that EE can change?

by Grand Master
Grand Master

Re: Change phones NAT TYPE

No. EE mobile uses Carrier Grade Nat (CGNAT), which means that you don't get your own IP address but share it with other users. So you can't be uniquely id'ed on the Net.

__________________________________________________________________________________________
If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by FrostbittenYeti
Explorer

Re: Change phones NAT TYPE

I was having this issue with my Nintendo Switch. Connecting to the internet ok but no online games.

 

I fixed it by adding a new access point.

 

This is in your phones network settings/data/advanced.

 

Named it Internet, set the same username and password as was used in the existing access point.

 

Username - eesecure

Password - secure

 

Didn't touch anything else and just saved. 

 

Switched to my new access point and had NAT B instead of D.

 

Not sure why this worked.

by
EE Community Support Team

Re: Change phones NAT TYPE

Hi @FrostbittenYeti,

 

Thanks for visiting the EE Community to share this great tip. Smiley Happy

 

James

by adamlab Investigator
Investigator

Re: Change phones NAT TYPE

hi I'm having the same issue now on my Nintendo switch I'm on May type c and need it on nat type b for it to work any ideas ho e to fix this issue

by adamlab Investigator
Investigator

changing nat type from C to B

hi group I've got a Nintendo switch and this EE mobile WiFi box. I am connected to the box but every time I do it keeps giving me nat type c and I need it on nat type b. I've asked a Facebook group and there telling me it's a nat type issue. I can see all my friends online etc but not able to play any online gaming. I have called up 150 and spoke with the ee Tec people but they don't have a clue how to fix this issue

by Grand Master
Grand Master

Re: Change phones NAT TYPE

by
EE Community Support Team

Re: Change phones NAT TYPE

Hi @adamlab,

 

Welcome to the EE Community.

 

Did @FrostbittenYeti's tip help?

 

Thanks

 

James

by adamlab Investigator
Investigator

Re: Change phones NAT TYPE

no still can't get it to work 

by FrostbittenYeti
Explorer

Re: Change phones NAT TYPE

I have noticed that when I created a new access point that there were a few extra things put under the option APN Type.

 

Try adding the below in your access point settings 

APN Type - default,mms,supl,hipri,fota,ims,cbs

 

Hope that helps 

by adamlab Investigator
Investigator

Re: Change phones NAT TYPE

still don't understand what you mean. I can see where you make a new access point but not sire what to put in all the boxs

by inkub69
Explorer

Re: Change phones NAT TYPE


@FrostbittenYeti wrote:

I was having this issue with my Nintendo Switch. Connecting to the internet ok but no online games.

 

I fixed it by adding a new access point.

 

This is in your phones network settings/data/advanced.

 

Named it Internet, set the same username and password as was used in the existing access point.

 

Username - eesecure

Password - secure

 

Didn't touch anything else and just saved. 

 

Switched to my new access point and had NAT B instead of D.

 

Not sure why this worked.


It's working. But I noticed when I just setup new access point, you just need change one setting in old one. It's "APN protocol" originally is typed "IPv4/IPv6" you need to change this and leave only "IPv4" this change my NAT from type 3 to NAT type 2.

Now I'm just wondering is it possible to get NAT type 1? Even my router from EE is giving me NAT type 2 for my ps4, is there any solution to change for NAT type 1?

by inkub69
Explorer

Re: Change phones NAT TYPE


@inkub69 wrote:

@FrostbittenYeti wrote:

I was having this issue with my Nintendo Switch. Connecting to the internet ok but no online games.

 

I fixed it by adding a new access point.

 

This is in your phones network settings/data/advanced.

 

Named it Internet, set the same username and password as was used in the existing access point.

 

Username - eesecure

Password - secure

 

Didn't touch anything else and just saved. 

 

Switched to my new access point and had NAT B instead of D.

 

Not sure why this worked.


It's working. But I noticed when I just setup new access point, you just need change one setting in old one. It's "APN protocol" originally is typed "IPv4/IPv6" you need to change this and leave only "IPv4" this change my NAT from type 3 to NAT type 2.

Now I'm just wondering is it possible to get NAT type 1? Even my router from EE is giving me NAT type 2 for my ps4, is there any solution to change for NAT type 1?


Nevermind about NAT type 1. I find answers, NAT type 2 is ok.

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.