by Em03

Apn setting

Yesterday I activated my New SIM card. I have a doogee x70 and my SIM card does not working. No internet, no phone, no sms please help 

by Grand Master
Grand Master

Re: Apn setting

@Em03 :

  1. Just manually search for EE as your Network Operator & it should auto set up your APN.
  2. You could just go to the online tool and download them to your phone.
  3. Look them up in

    EE APN Settings: Where to find them .

If you think I helped please feel free to hit the "Thumbs Up" button below.

To phone EE: The local rate landline number +44 207 362 0200 or Freephone +44 800 079 8586 - Option 1 for Mobiles; Option 2 for 4G WiFi; Option 3 for Home Broadband & EE TV.

ISPs: 1999: Freeserve 48K Dial-Up => 2005: Wanadoo 1 Meg BB => 2007: Orange 2 Meg BB => 2008: Orange 8 Meg LLU => 2010: Orange 16 Meg LLU => 2011: Orange 20 Meg WBC => 2014: EE 20 Meg WBC
by Grand Master
Grand Master

Re: Apn setting


just looking at the connection type that device supports and you’ll only get 2G with EE.  The device doesn’t support 4G and the device will not pick up EEs 3G network.     The device is not really compatible with EE network.    

Please read THIS and look at the GSM and mobile network.  

these are the EE bands and what they used for. 

  • 800MHz(band 26) for 4G
  • 1800MHz(band 3) for 2G and 4G
  • 2100MHz(band 1) for 3G only
  • 2600MHz(band 7) for 4G


by Em03

tried Re: Apn setting

I tried the Android setting but did not work other option?

by Grand Master
Grand Master

Re: tried Re: Apn setting

@Em03   The best option is to change network to a network that supports the device and the bandwidths it has,  or purchased a device that can be used on EE.  That device is not compatible with EE as you’ll only pickup a 2G signal. 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.

Recent solutions