by djmonsta
Explorer

4G very slow since 5G launch

I have noticed that pretty much the day of the 5G launch 4G has been very slow, like unusable slow. I remember the same thing happening to 3G when 4G launched.

 

Why is this? Is it because the network can't reliably support both at full speed? Or is it a marketing tactic to force users into upgrading?

7 REPLIES 7
by Grand Master
Grand Master

Re: 4G very slow since 5G launch

@djmonsta  It’s not marketing tactics as 5G is only in a few areas so that would be pointless.  Are you in a 5G area ?  

by djmonsta
Explorer

Re: 4G very slow since 5G launch

Just outside London so probably not. Point taken, but it's gotta be more than just a coincidence as it happened with the 4G launch too?

by Grand Master
Grand Master

Re: 4G very slow since 5G launch

@djmonsta 

 

It's also probably weather related. 

 

Thanks




To contact EE Customer Services dial 150 From your EE mobile or 07953 966 250 from any other phone.

EE standard opening hours are 8am to 9pm weekday, 8am to 8pm on weekends.
by
EE Community Support Team

Re: 4G very slow since 5G launch

Hi @djmonsta,

 

Welcome to the EE Community. 🙂

 

Does the Network Status Checker show any problems in your area?

 

Thanks

 

James

 

 

by Tornado-Saq Valued Contributor
Valued Contributor

Re: 4G very slow since 5G launch

@djmonsta  I reckon it is a Marketing tactic because I had the same issue as you with 3G.  4G was only in certain areas before expanding and the same will occur again. 

 

At the moment, my 4G seems to be fine, but I know it will slow down.  

Highlighted
by CJ101 Investigator
Investigator

Re: 4G very slow since 5G launch

Absolutely it’s a marketing choice to slow down 4g. I live in London and travel around London all day every day, and since the 5g promo started, coverage and speed have gone flat. It literally feels like 3G have the time. The amount of money I spend per month on their contracts, I’m raging. And if I have to read an EE customer service message asking if I've checked my network status one more time!!! 😡

by
EE Community Support Team

Re: 4G very slow since 5G launch

Hi @CJ101

 

I've replied to your other post regarding this. Please take a look.

 

Thanks


Chris

 

 

Can't find what you're looking for?

One of these options may help you find the answers you need.

Let's get started

Join the EE Community to ask, answer, learn and share.